DSPE 4 Dummies

A quick & dirty guide for first time users of
DOMAIN-SPECIFIC LANGUAGE FOR PARALLEL REAL-TIME STREAM PROCESSING
Part 1 - Creating a single project

1) Open the right Perspective:
   • on the menu bar → **Window → Open Perspective → Other…**
   • on the dialog box → **System Designer → OK**

2) Create the system
   • on the menu bar → **File → New → System**
   • on the dialog box → write the **System Name** → **Finish**

3) Create a Gate
   • right click on the System → **New Definition**
   • on the dialog box → **Gates → Standard Gate** → write the **Definition Name** → **Next**
   • on the next page → choose the **Gate Type** → **Finish**
4) Create a Software Unit
   • right click on the System → New Definition
   • on the dialog box → Units → Software Unit → write the unit Definition Name → Next
   • on the next page → UnitBehaviour Type → select Cimplementation → Finish

5) Create a new Configuration
   • right click on the System → New Definition
   • on the dialog box → Structures → Configuration → write the Definition Name → Finish
6) Add SoftwareUnits to Configuration
   • click on the row at the left of Configurations
   • double click on Configuration name → this opens an editor on right
   • drag and drop the Software Unit from the right palette to the side of the Configuration

7) Add Gates to Software Unit
   • double click on Software Unit Name → this will open an editor on right
   • drag and drop the Gate from the right palette to the side of the Software Unit (first to Parameter input then to Parameter Output)
   • click on the names (on borders of the Software Unit) and rename the parameters

8) Create Runner
   • right click on the System → New Definition
   • on the dialog box → Runners → GUIApplication → write the Definition Name → Next
   • On the next page → Use Existing → Finish
9) Add Gates to Runner
   • double click on Runner Name →
     this will open an editor on right
   • drag and drop the Gate from the right palette to the
     side of the Runner
     (first to Parameter input then to Parameter Output)
   • click on the name (on borders of the Software Unit)
     and rename the parameters

10) create Link between Gates
    • select the **Link** tool from the right palette
      to the side of the Runner
    • click on the source Gate →
      click on the destination Gate
    • repeat until the links are done

11) Validate
    • right click on the System → **Validate**
    • it should display errors →
      Verify using the **Problems** tab in the
      bottom window.
      (in this case we need default value for the
      Gates)
12) Correct
- double click on Gate name → it will open an editor
- check HasDefaultValue and write a convenient value into the box marked as DefaultValue
- redo phase 10 - Validation

13) Add some code – i.e. forward data using Processing Phases
- double click on software unit implementation name it will open an editor
- expand Processing Phases
- activate only HasProcess
- in Process write the assignment

14) Generate
- right click on the System → Generate

15) Compile
- click on the tab Project Explorer
- right click on the Project with suffix _wx → Build Project

16) Run
- click on the tab Project Explorer
- click on the Project with suffix _wx to expand
- click on Binaries to expand
- right click on the executable name → Run As → Local C/C++ Application
Part 2 – Converting management from normal to event

1) Open the right Perspective:
   • on the menu bar → Window → Open Perspective → Other…
   • on the dialog box → System Designer → OK

2) Copy and rename Software Units
   • click on the arrow on the left of System this expands the System structure
   • click on the arrow on the left of SoftwareUnits this expands the list of Software Units
   • click on the name of the Software Unit
   • press keys CTRL and C this copy the Software Unit
   • press keys CTRL and V this paste the Software Unit

   • a Name Conflict dialog box will appear → rename the Cimplmentation name
   • click OK to confirm

3) Copy and rename CImplementation
   • click on the arrow on the left of System this expands the System structure
   • click on the arrow on the left of CImplementations this expands the list of CImplementations
   • click on the name of the CImplementation
   • press keys CTRL and C this copy the CImplementation
   • press keys CTRL and V this paste the CImplementation

   • a Name Conflict dialog box will appear → rename the CImplementation name
   • click OK to confirm
4) Copy and rename Gates
   • click on the arrow on the left of System 
     this expands the System structure 
   • click on the arrow on the left of StandardGates 
     this expands the list of Standard Gates 
   • click on the name of the Standard Gate 
   • press keys CTRL and C 
     this copies the Standard Gate 
   • press keys CTRL and V 
     this pastes the Standard Gate 

   • a Name Conflict dialog box will appear → 
     rename the Standard Gate name 
   • click OK to confirm

5) Morph CImplementation
   • click on the arrow on the left of System 
     this expands the System structure 
   • click on the arrow on the left of CImplementations 
     this expands the list of CImplementations 
   • right click on the name of the copy of CImplementation → Morph To → 
     StateImplementationDefinition 
     this opens a dialog box to confirm the operation 
   • assure that Update references to morphed definition is checked 
   • click on OK 
     you can see the morphed (transformed) implementation listed into StateImplementations
6) Morph Gates
   - click on the arrow on the left of System	his expands the System structure
   - click on the arrow on the left of StandardGates this expands the list of Standard Gates
   - right click on the name of Standard Gate → Morph To → EventGateDefinition
this opens a dialog box to confirm the operation

   - assure that Update references to morphed definition is checked
   - click on OK
you can see the morphed (transformed) implementation listed into EventGates

7) Edit Software Unit to change Standard Gates with Event Gates
   - click on the arrow on the left of System this expands the System structure
   - click on the arrow on the left of SoftwareUnits this expands the list of Software Units
   - double click on the name of the modified Software Unit
this opens the Software Unit Editor

   - click on the Gate → press DEL key
this deletes the gate
   - drag and drop the Event Gate from the right palette to the side of the Software Unit
   - click on the names (on borders of the Software Unit) and rename the parameters as before
(it is needed to not modify Implementation)

8) Edit Software Units to align to their State Implementation
• click on the arrow on the right of the title to expand the header

• double click on the right part of the line with the implementation name (not on the word “Production” nor “Simulation”) this open a scroll list with the names of the implementation

• choose the name of the morphed implementation (the one that begins with StateImplementation)
• repeat this for the two rows

9) Edit StateImplementation to add reference to SoftwareUnit
• click on the arrow on the left of System this expands the System structure
• click on the arrow on the left of StateImplementations this expands the list of StateImplementations
• double click on the name of the modified StateImplementation this opens the StateImplementation Editor

• change the reference to the Unit using the dropdown list
• click on the cross at the right of the StateImplementation name on the tab to close the StateImplementation editor
• click on Yes in the confirmation dialog box
10) Create a new Scheduler
   • right click on the System → New Definition
   • on the dialog box → Structures → Scheduler →
     write the Definition Name → Finish

11) Add SoftwareUnits to Scheduler
   • click on the row at the left of Schedulers
   • double click on Configuration name
     this opens an editor on right
   • drag and drop the Software Unit from the right
     palette to the side of the Scheduler
12) Create Runner
   • right click on the System → New Definition
   • on the dialog box → Runners → GUIApplication → write the Definition Name → Next
   • on the next page → Use Existing → select the Scheduler → Finish

13) Add Gates to Runner (as in part 1)
   • double click on Runner Name (this will open an editor on right)
   • drag and drop the Gate from the right palette to the side of the Runner

14) Create Links to Runner (as in part 1)
   • select the Link tool from the right side palette
   • click on the source Gate → click on the destination Gate
   • repeat until the links are done

15) Hints
   • remember that at least one Software Unit need to catch initEvent
   • open the State Implementation double clicking on the name
   • click on the arrow at the left of State Support to open this section
   • change EventSupportType to Immediate
   • flag AcceptInitEvent

16) Validate (as in part 1)
   • right click on the System → Validate
   • it should display errors
   • verify using the Problems tab in the bottom window.
17) Generate (as in part 1)
   • right click on the System → Generate

18) Compile
   • click on the tab Project Explorer
   • right click on the Project with suffix _wx → Build Configuration → Set Active → select the configuration that begins with the event runner (you can chose both Release or Debug)
   • right click on the Project with suffix _wx → Build Project
Part 3 – Converting management from event to coproc

1) Open the right Perspective:
   • on the menu bar → Window → Open Perspective → Other...
   • on the dialog box → System Designer → OK

2) Copy and rename Software Units
   • click on the arrow on the left of System this expands the System structure
   • click on the arrow on the left of SoftwareUnits this expands the list of Software Units
   • click on the name of the Software Unit
   • press keys CTRL and C this copies the Software Unit
   • press keys CTRL and V this pastes the Software Unit
   • a Name Conflict dialog box will appear → rename the SoftwareUnit name
   • click OK to confirm

3) Copy and rename State Implementations
   • click on the arrow on the left of System → this expands the System structure
   • click on the arrow on the left of StateImplementations this expands the list of State Implementations
   • click on the name of the State Implementation
   • press keys CTRL and C this copies the State Implementation
   • press keys CTRL and V this pastes the State Implementation
   • a Name Conflict dialog box will appear → rename the State Implementation
   • click OK to confirm
4) Morph State Implementations
   • click on the arrow on the left of System→this expands the System structure
   • click on the arrow on the left of StateImplementations
     this expands the list of State Implementations
   • right click on the name of the copy of State Implementation → Morph To → CoprocImplementationDefinition
     this opens a dialog box to confirm the operation

   • assure that Update references to morphed definition is checked
   • click on OK
     you can see the morphed (transformed) implementation listed into CoprocImplementations

5) Edit Software Units to align to their Coproc Implementation
   • click to the arrow on the right of the title to expand the header

   • double click on the right part of the line with the implementation name (not the word “Production” nor “Simulation”)
     this opens a scroll list with the names of the implementation

   • choose the name of the morphed implementation (the one that begins with CoprocImplementation)
   • repeat this for the two rows
     Edit CoprocImplementation to add reference to
SoftwareUnit

• click on the arrow on the left of System
  this expands the System structure
• click on the arrow on the left of CoprocImplementations
  this expands the list of CoprocImplementation
• double click on the name of the modified CoprocImplementation
  this opens the CoprocImplementation Editor

• change the reference to the Unit using the dropdown list
• click on the cross at the right of the CoprocImplementation name on the tab to close the CoprocImplementation editor
• click on Yes in the confirmation dialog box

7) Create a new Scheduler
• right click on the System → New Definition
• on the dialog box → Structures → CoprocScheduler
• write the Definition Name → Finish
8) Add SoftwareUnits to Scheduler
   • click on the row at the left of Schedulers
   • double click on Configuration name → this opens an editor on right
   • drag and drop the Software Unit from the right palette to the side of the Scheduler

9) Create Runner
   • right click on the System → New Definition
   • on the dialog box → Runners → GUIApplication → write the Definition Name → Next
   • on the next page → Use Existing → select the Scheduler → Finish